Need help with bot please

i cant add my bot to my server but i can to other servers. why is this ??

It appears that this may not be a problem with restorecord, but rather an issue with other bots such as Wick. Wick Bot has a tendency to kick or ban unverified new bots, so it is suggested that you review the audit logs to determine the cause of the problem.

i dont have wick added to server, will check logs rq!

It’s possible that Discord is experiencing an issue. You can try giving the bot administrative permissions and placing its own role above the verified/member role to see if you can ping it. This may help resolve the issue. If this does not work, you may want to check the audit logs to see if there are any clues as to the cause of the problem.

i got it fixed but bot wont respond to cmmnds to set up the mbed to verify any idea? thank you very much for the help

The issue may be related to your subscription or the configuration of the bot. Can you confirm which subscription you have? If you have a business subscription, you should be able to use commands by following the instructions at this link: Enable Slash Commands. If the bot is still not responding to commands after following these steps, try refreshing the commands by editing the bot and clicking “Refresh Commands”. If these suggestions do not help, it may be necessary to further troubleshoot the issue in order to identify and resolve the problem.

yes i do have the business plan nd the bot isnt even showing online or anything. do i need to make a new one?

To enable commands in restorecord, follow these steps:

  1. Copy the Public Key from Discord and add it to your restorecord bot, then save the changes.
  2. Add the interaction URL: https://restorecord.com/api/interaction
  3. When editing your bot on restorecord, click the “Refresh Commands” button.

After completing these steps, you should be able to use commands with your restorecord bot in Discord.

says my client secret is invalid ormissing but i just reset it nd updated it all nd still getting the same error